Need help implementing the ajax version - no results ever show up

Mark Borst's Avatar

Mark Borst

15 Jun, 2012 12:17 PM

Hello,

I am trying to use this plugin, but am having some issues getting the ajax call to work properly. You can see my form here:
http://www.rampantimaginations.com/autocomplete/

The page that generates the json (which I have validated is valid w/jlint) is here:
http://www.rampantimaginations.com/porttypes.cfm

When I use Firebug, I see that the request is sent, and comes back fine with a 200, and returns the correct json data, but nothing is ever put in the autosuggest list. It always reads "No Results Found".

I am sure it's something I am doing wrong, but can't for the life of me figure out what it is.

Has anyone else experienced this issue, or know how I can solve it?

I appreciate any help anyone can provide.

-=Mark

  1. 1 Posted by Jon on 18 Jun, 2012 08:11 AM

    Jon's Avatar

    My JSON is different:

    [{"value":"50","name":"50"},{"value":"todos","name":"Todos"}]
    
  2. 2 Posted by Mark Borst on 18 Jun, 2012 12:01 PM

    Mark Borst's Avatar

    Thanks,

    I realized this yesterday. Appreciate the sanity check! It's working now.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac